Having a hard time telling the BIOS to always boot from my DVD drive first

Discussion in 'Windows OS Support (Vista and newer)' started by 357mag, May 15, 2017.

  1. 357mag

    357mag

    Joined:
    Jul 24, 2004
    Messages:
    444
    I have set things up in my BIOS and I've told it to boot from my ASUS DVD Drive first. When I look into Advanced Mode it shows something like this:

    Boot Option Priorities

    1. UEFI ASUS DRW
    2. Intel SSD 120 GB

    But when I load a bootable disc in my ASUS drive, it gets bypassed.

    Now I can boot from that drive if I open the BIOS screen and where it says on a button Boot Options or something I get like a Quick Boot menu and if I hit ASUS in that menu then the system boots from that drive.

    But I gotta tell you I recently installed the newer version of Macrium Reflect Free Version and in this version you can make a bootable menu, so you no longer have to use any kind of recovery disc to restore your computer.

    So maybe because I did that option, it is now always bypassing the ASUS drive not wanting to boot from it?

    Perhaps that's the way it is expected to run?

    Just wanna make sure.
     
  2. tmathews

    tmathews

    Joined:
    Mar 23, 2006
    Messages:
    710
    Are you running W8/W8.1/W10? If so, you might try disabling Fast Startup to see if it's skipping the boot device check in order to boot faster.

    My test system has an old Asus DVD-RW that takes a fairly long time to come ready. The BIOS counts down from 30 seconds, with the drive coming up in about 10, but I could imagine another BIOS having a shorter timeout and skipping the drive if it's too slow to respond. Does it have the same problem if you set it to boot from USB first then give it a bootable flash drive?
     
  3. 357mag

    357mag

    Joined:
    Jul 24, 2004
    Messages:
    444
    No I'm not using Windows 8 or 10. Right now I'm on Windows 7. I haven't tried booting from a flash drive.
     
  4. glc

    glc Forum Administrator Staff Member

    Joined:
    May 26, 2000
    Messages:
    49,187
    Location:
    Joplin MO
    If you are running Windows 7, I'd advise you to use legacy boot instead of UEFI. However, if you switch now you may have to reinstall Windows.
     
  5. 357mag

    357mag

    Joined:
    Jul 24, 2004
    Messages:
    444
    Okay how do I set up legacy boot? Never heard of it. Is that a setting I can enable in my boot menu?
     
  6. glc

    glc Forum Administrator Staff Member

    Joined:
    May 26, 2000
    Messages:
    49,187
    Location:
    Joplin MO
    It's a bios setting. Where it is in the bios menus and what it is called depends on the brand and model of the board.
     
  7. reggie14

    reggie14

    Joined:
    Feb 1, 2015
    Messages:
    749
    If you just mean enabling CSM mode, then you can safety do that even if the OS is using GPT (which requires UEFI). CSM mostly just means the UEFI BIOS is willing to run code during boot that was written for legacy BIOS. It'll still boot to an EFI bootloader if that's what it finds. Note, if you actually want legacy code to run, you probably need to disable UEFI Secure Boot in addition to disabling CSM.

    I agree this is likely a UEFI problem of some sort. UEFI systems want to boot quickly, so they skip over things that were some in the legacy BIOS cases. Enabling CSM, disabling Secure Boot, and disabling any "Fast Boot" settings in the BIOS settings might do it.

    Or you can just continue to manually use the boot menu when you want to boot off a CD/DVD.
     
  8. 357mag

    357mag

    Joined:
    Jul 24, 2004
    Messages:
    444
    Actually I had my system to first check my DVD Drive to see if a bootable disc was in there and my computer would always boot from that first. But I think that when I created a boot menu in Macrium that is what caused the change.

    It worked the way I wanted before always first checking the optical drive. If there wasn't a bootable disc found then it booted from the system drive.

    My board is an ASUS P8P67 Pro.

    I looked around in the menus and I didn't find anything labeled UEIF.
     
  9. glc

    glc Forum Administrator Staff Member

    Joined:
    May 26, 2000
    Messages:
    49,187
    Location:
    Joplin MO
    I downloaded the manual for that board and I don't see any selections you can make for secure/legacy boot, CSM, or fast boot. About the best you can do is press F8 on startup to enter the boot menu, insert the DVD, let it spin up, then select the DVD drive to boot.

    I would recommend you do this in the BIOS - use advanced mode, go into Boot, and turn off the full screen logo. This will show you the POST screen and you can see what's going on.